Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-04-2009, 12:58 AM   #1
Ensign
 
Join Date: Aug 2009
Posts: 2
Default Limp Mode on 7.4 Merc

My engine goes into the limp mode at 3000 rpm. We checked the water supply and found some blockage which we removed. Next, we checked the lower unit oil, it was ok, then we looked at engine oil, it was ok. What is the next thing we should check. Oh yes compression check was good. :?:
__________________

maxum2900 is offline   Reply With Quote
Old 09-04-2009, 03:27 AM   #2
Admiral

 
seapuppy's Avatar
 
Join Date: Nov 2005
Location: Everett Wa
Posts: 4,681
Default Re: Limp Mode on 7.4 Merc

welcome to the zoo.....I moved this one from the suggestion forum to the general...more appropriate there..


as for your problem...when it goes into limp back mode..there is a code that needs to be read from the computer....your going to need to get a qualified tech in there to read the code...


SP :hello:
__________________
Don't compare your life to others. You have no idea what their journey is all about.
------------------------
SSN683 Association member
Par Excellence
------------------------------
2008 Bayliner 340 - "Wild Whim"
--------------------------------------
I live in my own little world....but it's okay-they know me here!!!

Avid practitioner of the martial art: KLIK-PAO.
Tap-Rack-Bang

Anyone that sez "Size doesn't matter" has never owned a boat!
seapuppy is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
R.I.P. MAXUM BOAT LINE!!!!! WE WERE DISCONTINUED TODAY!!!!! Bella Sera 3300SCR The Dock Walk 1 08-26-2009 09:39 PM
ENGINE REVS DROP zt260 Engines 3 09-15-2008 02:13 PM
fuel flow figures for 6.2mpi zt260 Maxum Owners General Discussions 4 09-07-2008 02:33 AM
5.7L 230HP 16X16? BillinPA Engines 6 12-18-2007 10:44 PM
GRP Polish Webblet Maxum Maintenance 8 08-16-2005 12:27 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 09:38 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.