Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-06-2014, 10:28 PM   #1
Ensign
 
Join Date: Mar 2014
Posts: 1
Default Have to pour gas into carb

Hi All,

My first post here as I'm a virgin here...so be gentle

I have a 1996 Maxum 1900SR with mercrusier 4.3L alpha drive

Last summer had lots of trouble starting the boat to the point where it would only start by pouring gas into the carb up to about 8+ times to get it to stay running...then would be ok all day until it sat for an hour or more.


Not sure if its fuel pump, need a carb rebuild or if the needle is stuck or something else???

any help to lead me in the right direction?

Cheers,
Craig
__________________

Craig68 is offline   Reply With Quote
Old 03-06-2014, 10:54 PM   #2
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Essex, Maryland
Posts: 7,604
Default

Craig welcome aboard.

I believe you have an electric fuel pump, correct?
If yes during cranking it gets power from the starter soleniod. Verify it's getting 12V at the pump when cranking.

Runs Ok once started?

Once running the fule pump gets 12V from the oil pressure switch but the engine must be running for the switch to close.
__________________
1997 2400 SCR
5.7 Vortec / Bravo 2
Mike
mmwjr is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 09:09 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.