Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-03-2008, 06:01 AM   #1
Ensign
 
Join Date: Mar 2008
Location: Scottsdale, AZ
Posts: 5
Default 1999 2100 SR 5.0 Alpha One Cavitation or Something

Hi there... New member, first post.

I just got my 2100SR back from the shop. Had impeller replaced, (regular maintenance), skeg replaced on stern drive and stainless prop fixed (wife chunked both last year putting boat on trailer). I ran the boat several times last year after the chunking with no problems.

I get the boat back, take it to the lake. (AZ) Boat starts right up no problem. First thing I notice when I put boat in gear is a faint rumbling, but forward and reverse seem to work fine. Next with stern drive down, I ease into the throttle, boat moves forward and at about 1800 RPM the RPMs shoot up and the boat slows down. I back off the throttle, recheck that sterndrive is down and try again, same result. I then limp back to dock at idle. temps were fine and no alarms on the way back

Boat is headed back to shop tommorrow. Could this be as simple as a "Spun Prop" or something else. Any help would be appreciated.
__________________

azmax is offline   Reply With Quote
Old 03-03-2008, 12:51 PM   #2
Commander
 
tglee's Avatar
 
Join Date: Feb 2007
Location: PA
Posts: 332
Default

Same thing would happen when I had a spun prop. Everything was ok until I hit 2000 RPM. At 2000 the tach. would shoot up to 5000 and the boat would slow to a crawl. Let us know how it tuns out.
__________________

__________________
"Democracy is two wolves and a lamb voting on what to have for lunch. Liberty is a well-armed lamb contesting the vote."

MMSI# 338052622
tglee is offline   Reply With Quote
Old 03-03-2008, 02:02 PM   #3
Admiral

 
seapuppy's Avatar
 
Join Date: Nov 2005
Location: Everett Wa
Posts: 4,681
Default

spun prop.....definitely....it happens...
__________________
Don't compare your life to others. You have no idea what their journey is all about.
------------------------
SSN683 Association member
Par Excellence
------------------------------
2008 Bayliner 340 - "Wild Whim"
--------------------------------------
I live in my own little world....but it's okay-they know me here!!!

Avid practitioner of the martial art: KLIK-PAO.
Tap-Rack-Bang

Anyone that sez "Size doesn't matter" has never owned a boat!
seapuppy is offline   Reply With Quote
Old 03-03-2008, 02:46 PM   #4
Ensign
 
Join Date: Mar 2008
Location: Scottsdale, AZ
Posts: 5
Default

Thanks for the info. That sounds alot less expensive than outdrive problem. Leaving for the shop now. I will post results
azmax is offline   Reply With Quote
Old 03-03-2008, 06:54 PM   #5
Ensign
 
Join Date: Mar 2008
Location: Scottsdale, AZ
Posts: 5
Default

Well I am back from the shop and the fix was a simple, but annoying one. After checking the prop hub, no damage, putting the boat on a dyno, no slippage, I pick up the prop and figure out that it isn't my prop. They had put on a 17 pitch, 14" diameter, VENTILATED, outboard prop, instead of my 19. The company that fixed the prop sent back the wrong one. Anyway, I will have my prop back tommorrow.

No charge for service and they gave me a 20% coupon fro next service.

Bullet Dodged

Again thanks for the feedback
azmax is offline   Reply With Quote
Old 03-03-2008, 08:24 PM   #6
Admiral

 
seapuppy's Avatar
 
Join Date: Nov 2005
Location: Everett Wa
Posts: 4,681
Default

awesome!!!...that's good news!!......
__________________

__________________
Don't compare your life to others. You have no idea what their journey is all about.
------------------------
SSN683 Association member
Par Excellence
------------------------------
2008 Bayliner 340 - "Wild Whim"
--------------------------------------
I live in my own little world....but it's okay-they know me here!!!

Avid practitioner of the martial art: KLIK-PAO.
Tap-Rack-Bang

Anyone that sez "Size doesn't matter" has never owned a boat!
seapuppy is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Usability (Not a Bug) shrew Forum Support | Suggestion Box | News 6 01-14-2010 04:20 PM
Stock Seats luv2getbig Maxum Maintenance 1 06-28-2009 02:03 PM
Notch in hard chine on 1800SR CWERICB Maxum Owners General Discussions 1 10-17-2008 03:30 PM
2700 towing points Ticamo Maxum Owners General Discussions 2 03-17-2008 07:22 PM
prop size for my boat? gezy Maxum Owners General Discussions 26 06-22-2007 06:50 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 08:15 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.