Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-18-2020, 10:12 PM   #1
Ensign
 
Join Date: Jul 2020
Posts: 3
Default Aloha! 99í 1900 SR

Aloha! I just purchased my first boat. Itís a 1999 1900 SR with the I/O 4.3. Iím a fairly competent mechanic having done everything short of a full engine tear down and rebuild.

Boat is 20+ years old and is in need of a lot of TLC and Iím pretty sure a new engine is in order. Iíll make anew post for that though.

Current list of needs,
5 of 7 gauges are bad.
4 Seats all have seam tears
A good compound/polish/wax
Restore dash/cowling vinyl.
Some small gel coat touch ups.
paint spiderwebbing on the swim deck.

If there are any other Oahu members, Iíd love to chat!
__________________

Gutie04 is offline   Reply With Quote
Old 07-18-2020, 11:00 PM   #2
Ensign
 
Join Date: Jul 2020
Posts: 3
Default

Engine posthttps://www.maxumownersclub.com/foru...html#post63098
__________________

Gutie04 is offline   Reply With Quote
Old 07-19-2020, 01:23 AM   #3
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Essex, Maryland
Posts: 8,239
Default

Welcome aboard!

Test the gauges to verify their the issue and not the senders. For most disconnect the sense wire and the gauge should read low the ground the sense terminal and they should read full scale.
__________________
1997 2400 SCR
5.7 Vortec / Bravo 2
Mike
mmwjr is offline   Reply With Quote
Reply

Tags
1900sr, mercruiser 4.3, new member

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 09:48 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.