Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-26-2008, 12:31 AM   #1
Lieutenant
 
Join Date: Mar 2008
Posts: 59
Default Merc 6.2L Operating Temp

The other day my temp seemed a bit high at 175. No alarms or anything, but it seemed higher than I remember (although maybe my memory is faulty). Anyone know the operating temp range for a Merc 6.2 I/O raw water cooled? (For what its worth this is a 2003 2700 SCR)

If that is high, I thought I would start with the thermostat, since that is cheap, move on to the impeller, and then risers/manifolds. Any other possibilities/suggestions?

Thanks.
__________________

Ticamo is offline   Reply With Quote
Old 08-26-2008, 12:45 AM   #2
Admiral

 
seapuppy's Avatar
 
Join Date: Nov 2005
Location: Everett Wa
Posts: 4,681
Default

welcome to the zoo...well...mine is FWC system....and I run at 175...the alarms will go off at about 195...don't ask how I know.... :shock:
but your fine...so..my first question is when was the last time you replaced the impeller...???..the second question is have you checked the drive for any obstructions...and finally.....is this the original thermostat with x number of hrs...if it has a ton of hrs....then yeah..that's one place to start...
oh yeah....next is ..what kind of water do you boat in..salt water will be more corrosive and what your experiencing maybe the breakdown of the manifolds....start with the impeller first if it's old....then move to the thermostat....check the risers and manifolds and if it's still running high..then take the plugs out and do a complete compression check....

SP
__________________

__________________
Don't compare your life to others. You have no idea what their journey is all about.
------------------------
SSN683 Association member
Par Excellence
------------------------------
2008 Bayliner 340 - "Wild Whim"
--------------------------------------
I live in my own little world....but it's okay-they know me here!!!

Avid practitioner of the martial art: KLIK-PAO.
Tap-Rack-Bang

Anyone that sez "Size doesn't matter" has never owned a boat!
seapuppy is offline   Reply With Quote
Old 08-26-2008, 09:49 PM   #3
Lt. Commander
 
Join Date: Aug 2007
Location: england
Posts: 174
Default

i run rwc 6.2 and 175 is fine its the correct operating temp
so enjoy
regds ash
__________________
1999 maxum 2800scr 6.2l b3
www.D-fenda.co.uk
zt260 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1992 2300 SCR Caledonia Maxum Owners General Discussions 3 12-07-2009 12:13 AM
adjusting shift linkage 06 1800mx tomjentommy Maxum Maintenance 10 10-19-2009 05:48 PM
fuel flow figures for 6.2mpi zt260 Maxum Owners General Discussions 4 09-07-2008 03:33 AM
just woke up from the Bayliner/Maxum Event seapuppy Maxum Owners General Discussions 0 05-30-2008 04:02 PM
GRP Polish Webblet Maxum Maintenance 8 08-16-2005 01:27 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 09:56 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.