Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-09-2019, 11:31 PM   #1
Ensign
 
Join Date: Oct 2018
Posts: 4
Default power steering fluid in the bilge

hi All,
I have a 96 2400SCR 5.7 merc. engine is new with 30 hours. I regularly find power steering fluid in my bilge (level always low). I put cardboard under front and rear. Nothing in the rear front wet in center area of engine. any ideas?
thanks in advance.
Tony
__________________

tonydive is offline   Reply With Quote
Old 07-10-2019, 01:02 AM   #2
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Essex, Maryland
Posts: 7,131
Default

The PS pump is on the port side so the leak is probably in that area. Typical cause is the front seal on the pump, try wiping it with a paper towel and see if it wet. On my 97 the PS cooler is located across the back of the engine but my 93 is was on the port side down low.
__________________

__________________
Mike
mmwjr is offline   Reply With Quote
Old 07-10-2019, 05:59 PM   #3
Ensign
 
Join Date: Oct 2018
Posts: 4
Default

thanks Mike
tonydive is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 07:52 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.