Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-13-2018, 12:44 AM   #1
Ensign
 
Join Date: Apr 2017
Posts: 6
Default Fresh water pump

I have a 2002 3300 SCR, the fresh water pump will run, build up pressure then stop, all normal. Issue is when i open a faucet the water pressure is good for about 1 second, then the pump continues to run but the water pressure is very very low. Shut the faucet and the pump builds pressure and stops.
Any advice?
__________________

mac62 is offline   Reply With Quote
Old 06-13-2018, 02:01 AM   #2
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Perry Hall, Maryland
Posts: 6,029
Default

Most pumps have a filter on them that will clog over time and restrict water flow. I would start here. Have tested this at different faucets?
__________________

__________________
Mike
mmwjr is offline   Reply With Quote
Old 06-13-2018, 02:09 AM   #3
Ensign
 
Join Date: Apr 2017
Posts: 6
Default

Yes, poor pressure at all when using on board tank
mac62 is offline   Reply With Quote
Old 06-13-2018, 02:11 AM   #4
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Perry Hall, Maryland
Posts: 6,029
Default

Ok if the filter is ok the pump is most likely weak and needs replacing.
__________________
Mike
mmwjr is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 05:30 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.