Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-21-2009, 05:35 PM   #1
Lt. JG
 
Whiskey River's Avatar
 
Join Date: Jul 2009
Location: Chapel Hill, NC
Posts: 44
Default Newbie to board w/engine questions

I just recently joined the Maxum owners, have been a Glastron owner for several years but due to growing family finally bit the bullet and purchased a larger boat with cabin.
Previous owner was not too boat savvy and didn’t winterize last year so after about 100 hours of labor and several thousand dollars later the family and I spent our first weekend on the boat this past weekend (and LOVED it).
I was a mechanic for 18 years therefore elected to do the engine swap myself rather than pay a marine two arms and three legs to do the job for me.
Boat now has a remanufactured 7.4MPI long block with all new exhaust, tune up, water pump etc. etc. etc.
I write my first post to introduce myself and to ask if anyone else has the 7.4 MPI and any experience with running rich at idle, boat has a slight hesitation when just staring off around 1000-2000 RPM’s then will take off and run like a bat out of H_ LL. The running rich at idle and hesitation are the only two signs of this problem (knocking on wood).
Also here are a few pictures please give your reviews.

Thanks,
WR




__________________

Whiskey River is offline   Reply With Quote
Old 07-21-2009, 05:44 PM   #2
Lieutenant
 
Join Date: Mar 2008
Posts: 59
Default Re: Newbie to board w/engine questions

Engine is distracted by bikini? :P

Sorry, no ideas from me. But anyone whose first post involves bikini pics is OK in my book. I am sure someone will jump in with something helpful.

BTW, I bet that thing does run like a bat out of h-ll w/ a 7.4 MPI.
__________________

Ticamo is offline   Reply With Quote
Old 07-21-2009, 05:51 PM   #3
Admiral

 
seapuppy's Avatar
 
Join Date: Nov 2005
Location: Everett Wa
Posts: 4,681
Default Re: Newbie to board w/engine questions

welcome to the zoo WW...first off....that air cleaner isn't regulation..you need a flame arrestor rather than an air cleaner by coast guard regs......second...if it's hesitating at first opening...then the air is leaning out at initial opening and then the mpi is richening out ....that tells me either your o2 sensor is bad or that your mapping is messed up....get someone with a merc computer to attach to the boat and do some diagnostics......that will tell you exactly what is wrong...

finally....7.4mpi engine in that small of a boat will rip that bikini right off her!!....niiiiiiicee!!!!!

what drive are you running cuz the a1g2 drives aren't rated for that big an engine..!!!

SP :hello:
__________________
Don't compare your life to others. You have no idea what their journey is all about.
------------------------
SSN683 Association member
Par Excellence
------------------------------
2008 Bayliner 340 - "Wild Whim"
--------------------------------------
I live in my own little world....but it's okay-they know me here!!!

Avid practitioner of the martial art: KLIK-PAO.
Tap-Rack-Bang

Anyone that sez "Size doesn't matter" has never owned a boat!
seapuppy is offline   Reply With Quote
Old 07-21-2009, 06:25 PM   #4
Lt. JG
 
Whiskey River's Avatar
 
Join Date: Jul 2009
Location: Chapel Hill, NC
Posts: 44
Default Re: Newbie to board w/engine questions

Seapuppy, I am running the Bravo 3 w/dual 24p stainless props.

And yes occasionaly the wind will blow that bikini right off .

Thanks for the tip on the aircleaner, I thought it looked good at first but have since replaced with original as you stated it is NOT CG approved and had hoped it may be contributing to the running rich (but no such luck).

I am looking for anyone who may have a used scan tool for sale as I know this will be a much needed tool in the future and all my fellow boaters and mechanics in my area do not have a mercruiser or similar scan tool.
Whiskey River is offline   Reply With Quote
Old 07-21-2009, 07:18 PM   #5
Lt. Commander
 
Join Date: Feb 2008
Location: Notts UK
Posts: 186
Default Re: Newbie to board w/engine questions

I don't know much about the MPI systems but can you check if the cold start system is switching off is the coolant sensor working correctly etc I've had this problem on a few injection cars before
__________________
Gaz
Gazjen is offline   Reply With Quote
Old 08-24-2009, 03:20 PM   #6
Lt. JG
 
Whiskey River's Avatar
 
Join Date: Jul 2009
Location: Chapel Hill, NC
Posts: 44
Default Re: Newbie to board w/engine questions

Just an FYI for the board..I found a very small fuel leak between the water seperator and fuel rial on the line feeding the fuel injection from the filter assy... Corrected leak and ran for about 5 minutes at about 1/2 throttle then back to idle.... Now runs like a sewing machine... Not sure if the leak was also causing it to pull air into line thus the reason it was leaning out at take off and loading up at idle... But (knock on wood) she runs like a champ from idle to WOT and back every time now with out any hesitation....

Just thought I would pass this info along to the board for referrence.

WR
Whiskey River is offline   Reply With Quote
Old 08-24-2009, 07:06 PM   #7
Commander
 
tglee's Avatar
 
Join Date: Feb 2007
Location: PA
Posts: 332
Default Re: Newbie to board w/engine questions

Thanks for the update.
__________________

__________________
"Democracy is two wolves and a lamb voting on what to have for lunch. Liberty is a well-armed lamb contesting the vote."

MMSI# 338052622
tglee is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Water tank removal 32scraz Maxum Maintenance 2 12-22-2008 01:38 PM
fall boating.!!. seapuppy Maxum Owners General Discussions 4 10-02-2007 09:52 PM
engine oil gezy Maxum Owners General Discussions 10 08-29-2006 08:42 PM
Thunderbolt V ICM Alpha Drive Maxum2300SC Buy | Sell | Trade 1 07-07-2004 04:03 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 06:50 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.