Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-24-2015, 07:01 PM   #1
Lt. Commander
 
mrt214's Avatar
 
Join Date: May 2013
Location: Pittsburgh,Pa
Posts: 172
Default Losing rpm on port engine only.

Ok guys here we go, I have twin 350s and 1 fuel tank. I am losing rpms on port engine only when I throttle up to 4500rpm. both engines run at 3000rpm but this is not enough for this boat. I have replaced these items so far.

1. Both water seperators
2. coil on port side
3. fuel filter inside carb on port engine

Now I am contemplating changing cap wires and rotor. I am open for suggestions.
Boat has 435hrs 1996 Maxum 3200SCR
__________________

__________________
Mike
mrt214 is offline   Reply With Quote
Old 08-24-2015, 09:58 PM   #2
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Essex, Maryland
Posts: 8,239
Default

When you say losing rpms do you mean it gets to 4500 under load and then drops off?

Check fuel pressure should be 6-7 psi.
__________________

__________________
1997 2400 SCR
5.7 Vortec / Bravo 2
Mike
mmwjr is offline   Reply With Quote
Old 08-24-2015, 10:03 PM   #3
Lt. Commander
 
mrt214's Avatar
 
Join Date: May 2013
Location: Pittsburgh,Pa
Posts: 172
Default

yes it is when under load getting on plane then engine rpm drops. I have considered the fuel pump.
__________________
Mike
mrt214 is offline   Reply With Quote
Old 08-24-2015, 10:10 PM   #4
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Essex, Maryland
Posts: 8,239
Default

Quote:
Originally Posted by mrt214 View Post
yes it is when under load getting on plane then engine rpm drops. I have considered the fuel pump.

Since you replaced the filters this is what I would check next as I would think its fuel related and not electrical as it makes power then drops off shortly after.
__________________
1997 2400 SCR
5.7 Vortec / Bravo 2
Mike
mmwjr is offline   Reply With Quote
Old 08-24-2015, 10:13 PM   #5
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Essex, Maryland
Posts: 8,239
Default

After checking the fuel pump I would look into a carb issue such as a float issue causing the carb bowl to go low.
__________________
1997 2400 SCR
5.7 Vortec / Bravo 2
Mike
mmwjr is offline   Reply With Quote
Old 08-24-2015, 10:15 PM   #6
Lt. Commander
 
mrt214's Avatar
 
Join Date: May 2013
Location: Pittsburgh,Pa
Posts: 172
Default

Yeah what the hell it's only money. haha
__________________
Mike
mrt214 is offline   Reply With Quote
Old 08-24-2015, 10:17 PM   #7
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Essex, Maryland
Posts: 8,239
Default

And as long as it's your money I am willing to spend it.
__________________

__________________
1997 2400 SCR
5.7 Vortec / Bravo 2
Mike
mmwjr is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 10:43 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.