Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-14-2020, 01:46 AM   #1
Ensign
 
Join Date: Jul 2020
Posts: 2
Smile Alarm Remains On

I have a 2001 Maxum 2100sr that I bought last year with 190 hours on it and it runs great! This past Saturday at the end of the day my ignition alarm would come on and stay on. Anyone experience this before? Its annoying and what would it mean?
__________________

Bobbynrenee1993 is offline   Reply With Quote
Old 07-14-2020, 01:52 AM   #2
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Essex, Maryland
Posts: 8,233
Default

Welcome aboard!

The alarm is wired to 3 sensors; low oil pressure, water coolant and gear lube reservoir. The last one is a common reason for the alarm, verify the lube level is correct.
__________________

__________________
1997 2400 SCR
5.7 Vortec / Bravo 2
Mike
mmwjr is offline   Reply With Quote
Old 07-14-2020, 02:02 AM   #3
Ensign
 
Join Date: Jul 2020
Posts: 2
Default

Thanks! I will definitely check it out in the morning. I replaced all that this spring and will check it out. Thanks again!
Bobbynrenee1993 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 05:59 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.