Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-15-2012, 03:56 PM   #1
Ensign
 
Join Date: Jul 2012
Location: Texas Gulf Coast
Posts: 11
Default 5.7 Liter Fuel Delivery Problems

Splashed my 2001, 3300 SCR in the water for the first time yesterday. Starboard engine fire right up and ran great for hours. Port side engine did not. I replaced the fuel filter, made sure it had gas in it (tank and filter) and still nothing. I then ran it a few minutes by dripping gas into the throttle body. After that I disconnected the fuel line from the throttle body to check for fuel flow into a coke bottle and I got nothing. Keep in mind, all the while I can hear the fuel pump and it sounds like it's running with no load (higher pitch whine). At this point I gave up. While on the way to put her up and after running the starboard engine for about 30 minutes, I tried the port side engine again and it started. It ran great for about an hour and then died. I'm thinking it was vapor locked or had something blocking the pickup. I havenít checked anything after putting her up to see if the secondary break down is related to the first. If you've got a tale to tell, let me have it. I'll be over here scratching my head.
__________________

dltisdal is offline   Reply With Quote
Old 08-15-2012, 04:11 PM   #2
Commander

 
Join Date: Jun 2008
Location: B.C. canada
Posts: 265
Default

change the anti siphon valve on the fuel tank $12.00 it is starving the fuel pump worth a try.
__________________

cunuck is offline   Reply With Quote
Old 08-15-2012, 06:15 PM   #3
Captain
 
pascavone's Avatar
 
Join Date: Nov 2010
Location: Massapequa, New York, United States
Posts: 762
Default

maybe something made a home in your gas take vent on the hulll?

if you have two gas tanks, on for each engine, then it could be under a vacuum.

i'd run it with the gas cap lose and see if that works.

if blockage, get the air compressor and push back the clog.

do you have electrical fuel pump or mechanical?

carbs or fuel injections?


if a carb, there is a small filler where the line goes into the carb, looks like a hex nut....

it could be a stuck or clogged needle valve or lose needle seat.
pascavone is offline   Reply With Quote
Old 08-16-2012, 04:28 PM   #4
Ensign
 
Join Date: Jul 2012
Location: Texas Gulf Coast
Posts: 11
Default

Thanks. I didn't know there ws such an animal. I figured the pump had some sort of check valve built into it.
dltisdal is offline   Reply With Quote
Old 08-16-2012, 04:30 PM   #5
Ensign
 
Join Date: Jul 2012
Location: Texas Gulf Coast
Posts: 11
Default

I'm pretty sure I only have one tank. I mean I know I have only one tank but I'm not so sure it doesn't have a partition in it. I'll check the vent also.
dltisdal is offline   Reply With Quote
Old 08-16-2012, 06:01 PM   #6
Commander

 
Join Date: Jun 2008
Location: B.C. canada
Posts: 265
Default

I really dont think there would be a partition no point.The anti siphon valve is on the tank where your fuel hose connect to the tank.Just a hose clamp to undo easy,good luck
cunuck is offline   Reply With Quote
Old 08-16-2012, 07:00 PM   #7
Commander
 
Join Date: Aug 2010
Location: Purcellville, VA.
Posts: 296
Default

Hold on a sec. here. If there is only 1 tank then it cannot be the vent. The Starboard engine is running so the pump is pushing fuel to it. Is there a seperate fual pump for each engine or is there a fual line splitter after the pump so it feeds both fuel filters?
If there is a splitter in there, you have a clogged line or something of the sort between the pump and the TBI. If it has a seperate pump for each engine, sounds like you have a pump problem or clogged line. I just can't see how 1 motor can run but the other can't if it was a vent issue.
mcoffey is offline   Reply With Quote
Old 08-16-2012, 10:16 PM   #8
Commander

 
Join Date: Jun 2008
Location: B.C. canada
Posts: 265
Default

there has to be 2 fuel pumps as well as 2 pickups from the tank .each motor will run on its own thats great thing about twins you have back up power.You can have more than one fuel tank but twins should run off the same tank
__________________

cunuck is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 04:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.