Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-04-2010, 03:50 AM   #1
Ensign
 
Join Date: Jan 2010
Location: Melbourne Australia
Posts: 10
Default Plastic Valve

Hi

On top of the hull issue we have had another significant problem. The shafts are water cooled we are told. Water is pumped into them constantly through valve I believe its called a glange valve. The problem was the connector was made of plastic. With the engines producing 480 horse power they vibrate a bit. Consequently the plastic connector sheared off. This meant the hose disconnected from the valve and pumped water constantly into the engine bay.

From the shot below you can see we stuck a plastic cork in the hole to stop the water flow. It happened on both engines!!. My mechanic replaced the connector with a brass one so that it could take the vibration of the engine.

When we found the problem we had several feet of water in the engine bay and the bilges working over time. I suggest anyone with the same boat have this changed as it will happen as the plastic connector will not handle the vibrations. This was all done under warrantee.
Attached Thumbnails
maxum.eng.JPG  
__________________

richardbroxham is offline   Reply With Quote
Old 02-05-2010, 05:06 PM   #2
Moderator

 
Join Date: Apr 2008
Posts: 4,916
Default

I oringially posted asking about year/model. I see from other posts this is a 3700
shrew is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 02:45 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.