Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-18-2020, 03:02 AM   #1
Ensign
 
Join Date: May 2020
Posts: 5
Default Neutral button stuck

Iíve gone through a search of stuck neutral buttons, but havenít seen a recent one, with a good fix. Just curious what, if any good remedy to unsticking the neutral button? The motor revs and revs but wonít go in gear. Any help is appreciated.
__________________

Patrickellis is offline   Reply With Quote
Old 05-18-2020, 11:10 AM   #2
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Essex, Maryland
Posts: 7,748
Default

Try spraying some PB Blaster around the button to see if that helps. The shifter may just be worn out, what year and model is it?
__________________

__________________
1997 2400 SCR
5.7 Vortec / Bravo 2
Mike
mmwjr is offline   Reply With Quote
Old 05-18-2020, 01:10 PM   #3
Ensign
 
Join Date: May 2020
Posts: 5
Default

The boat is a 2006, 1900 with carbureted 4.3.
Patrickellis is offline   Reply With Quote
Old 05-18-2020, 04:50 PM   #4
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Essex, Maryland
Posts: 7,748
Default

Quicksilver 3000 throttle control?
__________________
1997 2400 SCR
5.7 Vortec / Bravo 2
Mike
mmwjr is offline   Reply With Quote
Old 05-18-2020, 05:33 PM   #5
Ensign
 
Join Date: May 2020
Posts: 5
Default

I don’t think so, when I do a google search, the images don’t look like mine. My controls are round and not squared off at all. But I used the PB and a pocket knife and got the button unstuck. The button had some grimy stuff in it I got it cleaned up and now it works smooth.
Patrickellis is offline   Reply With Quote
Old 05-19-2020, 01:28 AM   #6
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Essex, Maryland
Posts: 7,748
Default

Quote:
Originally Posted by Patrickellis View Post
I donít think so, when I do a google search, the images donít look like mine. My controls are round and not squared off at all. But I used the PB and a pocket knife and got the button unstuck. The button had some grimy stuff in it I got it cleaned up and now it works smooth.
Good to hear. The newer version of the Quicksilver was rounder, may be a 4000.
__________________
1997 2400 SCR
5.7 Vortec / Bravo 2
Mike
mmwjr is offline   Reply With Quote
Old 05-19-2020, 04:39 PM   #7
Lt. Commander
 
forbes210's Avatar
 
Join Date: Nov 2013
Location: Staten Island, NY
Posts: 134
Default

+1 Mike

I had that issue and one day I spray WD40 around the button with rag around it. As simple and silly method it was it worked perfectly.
__________________

forbes210 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 05:42 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.