Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-08-2024, 11:51 PM   #1
Ensign
 
Join Date: Jul 2024
Posts: 1
Default radio turns on but none of the speakers make a sound

Hi boating community,

New owner of 1996 Maxum 2400 SCR. Getting to know more about all systems. The radio/cd player lights up when I turn the power switch on radio on, volume indicator looks to work, too. And radio frequency shows local radio stations. But there is no sound from any of the interior or exterior speakers. Is this a fuse thing? Is there a toggle on dash? Looking for suggestions to fix.

Thanks,

Jim
__________________

Jlister is offline   Reply With Quote
Old 07-09-2024, 01:42 AM   #2
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Essex, Maryland
Posts: 10,419
Default

Nope either the radio is bad and the channels are blown or the speaker wires are open of they are blown. You can try pulling the radio out and wire a good speaker directly to it to see if it works. If not the radio needs replacement.
__________________
1997 Silverton 362, 7.4 Crusaders
1997 2400 SCR, 5.7 Vortec / Bravo 2

Mike
mmwjr is offline   Reply With Quote
Reply

Tags
radio speaker fuse

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 02:45 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2024, vBulletin Solutions, Inc.