Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-17-2015, 11:01 AM   #1
Lt. JG
 
Join Date: May 2013
Location: Scotland
Posts: 26
Default Ignition Coil

Guys,

Looking for some advice.

Last year I had issues with the engine on my 2400SC (350 MAG) misfiring and for about 2 weeks won't go over 2000RPM. This issue seemed to resolve itself after the distributor cap was cleaned.

However, it came back again at the end of the season so at the start of this season we replaced the distributor, rotor and spark plugs and the engine seemed fine. Last week the misfire started again. We then changed the leads in the hope that it would take car of the problem once and for all. This didn't work either, in fact the misfire / banging from the engine has gotten worse.

I spoke with the Mercruiser mechanic who I always use and he has told me that the only thing that we haven't changed and which could be causing these symptoms is the ignition coil.

What's your thoughts on this? Could this be caused by anything else?

I'm sure its an electrical issue. I've asked him to try another coil before he goes and orders a new one (I've changed plenty of parts over the years to the discover that it hasn't resolved the problem)

Has anyone had this before?

Thanks for advice in advance.

Cheers,
Ernie
__________________

Ernie is offline   Reply With Quote
Old 06-17-2015, 11:36 AM   #2
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Essex, Maryland
Posts: 7,788
Default

Ernie, when you say replaced the distributor I am assuming you mean the distributor cap, correct?

350 Mag is a fuel injected engine and your mechanic should be able to read out engine codes telling what the issue is. Without more info it hard to say but yes it could be a bad coil or an issues with the fuel injection system.

What year is the boat and engine?
__________________

__________________
1997 2400 SCR
5.7 Vortec / Bravo 2
Mike
mmwjr is offline   Reply With Quote
Old 06-28-2015, 02:59 AM   #3
Lt. JG
 
Join Date: Jan 2006
Location: Canby, OR. USA
Posts: 30
Default

Maybe a spark plug wire
__________________
97 2700 SCR 7.4l BII
II Lucky is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 01:35 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.