Showing results 1 to 8 of 8
Search took 0.01 seconds.
Search: Posts Made By: tomjentommy
Forum: Engines 05-05-2010, 12:49 AM
Replies: 2
Views: 1,069
Posted By tomjentommy
Ok well i was being a bit lazy with my...

Ok well i was being a bit lazy with my description. I will start over the boat had been sitting for a while and would idle but would stall during acceleration, i came to the conclusion that the carb...
Forum: Engines 05-01-2010, 06:19 PM
Replies: 2
Views: 1,069
Posted By tomjentommy
3.0l carburetor dumping fuel

i have an 2006 3.0L the fuel is is just pouring from the venturi cluster does anyone have any idea what would cause this?
Forum: Maxum Maintenance 02-28-2009, 11:34 PM
Replies: 10
Views: 3,342
Posted By tomjentommy
yes i finally gave in and took it to mechanic and...

yes i finally gave in and took it to mechanic and of course he told me the linkage needed to be adjusted took him about five minutes to fix what i spent month playing with. wont do that again.
Forum: Maxum Maintenance 02-28-2009, 11:31 PM
Replies: 5
oil
Views: 1,864
Posted By tomjentommy
oil

going to chenge the oil in my 1800 mx 3.0 for the first time any recomendations on the best oil to use
Forum: Engines 08-31-2008, 10:33 PM
Replies: 4
Views: 1,812
Posted By tomjentommy
i dont think getting them out wuld be a problem...

i dont think getting them out wuld be a problem however putting them back in might be beside if you have the motor out you might aswell strip of the heads and everything else
Forum: Maxum Maintenance 08-31-2008, 10:30 PM
Replies: 10
Views: 3,342
Posted By tomjentommy
adjusting shift linkage 06 1800mx

so my problem is when I am moving forward then put it where nuetral is supposed to be it is still idleing forward. also when i attempt to put it in reverse it grind or clicks what ever you want to...
Forum: Electronics 08-31-2008, 10:22 PM
Replies: 3
Views: 1,879
Posted By tomjentommy
actually no i have not added anything lately....

actually no i have not added anything lately. however since posting this i found that the problem is starting in the toggle marked for accy by disconnecting each switch at a time i was able to find...
Forum: Electronics 08-30-2008, 01:29 AM
Replies: 3
Views: 1,879
Posted By tomjentommy
toggle switch problem

Ok sa I have a 05 1800mx about a week ago the toggle switch for my bilge broke off. i replaced it today and had the power on while i was doing this, while under the dash all of the rest of my...
Showing results 1 to 8 of 8

 
Forum Jump

All times are GMT. The time now is 08:44 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.