Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-09-2017, 10:28 PM   #1
Ensign
 
Join Date: Aug 2016
Location: England
Posts: 12
Default Stereo not working

Hi everyone, I am the proud new owner of a 2800SCR, built in 2000. I am in the U.K. and looking forward to my first season with her. I am slowly getting to know her but at the moment cannot get the stereo to switch on. Is there an isolator switch or fuse I should check before I think about more costly solutions? Any advice gratefully received, thanks
Jason
PS the rest of the electrics seem fine so I am thinking that the stereo might need replacing but wanted to check first with other owners
__________________

JasonD is offline   Reply With Quote
Old 05-10-2017, 02:02 AM   #2
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Perry Hall, Maryland
Posts: 5,397
Default

Welcome aboard

First multi posts on the same topic does not yield a quicker or better response.

Under the helm should be the fuse panel with a separate fuse for the radio. If that checks out ok pull the radio and verify 12V is present on the power going to it, red wire. Also verify it has a good return black wire. If these check out then the radio is bad.
__________________

__________________
Mike
mmwjr is online now   Reply With Quote
Old 05-10-2017, 03:21 AM   #3
Ensign
 
Join Date: Aug 2016
Location: England
Posts: 12
Default

Thanks Mike, sorry I didn't mean to post multiple questions, I couldn't find how to create a new thread so tagged onto another topic, then found how to do it but didn't delete other post. Anyway I think I have worked it out now!
I will try out your suggestion, thanks ��
JasonD is offline   Reply With Quote
Old 05-10-2017, 11:17 AM   #4
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Perry Hall, Maryland
Posts: 5,397
Default

Quote:
Originally Posted by JasonD View Post
Thanks Mike, sorry I didn't mean to post multiple questions, I couldn't find how to create a new thread so tagged onto another topic, then found how to do it but didn't delete other post. Anyway I think I have worked it out now!
I will try out your suggestion, thanks ��
Post back on what you find out.
__________________
Mike
mmwjr is online now   Reply With Quote
Reply

Tags
stereo

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 11:22 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.