Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-13-2019, 10:29 PM   #1
Ensign
 
Join Date: May 2019
Posts: 4
Default Newbie

Hi Everyone, I have a 1994 Maxum 2000SC that I've been restoring. When I take it out it makes a clicking sound when you turn the wheel left or right while backing up.Any ideas as to what that may be?
__________________

Bobaluah is offline   Reply With Quote
Old 05-14-2019, 12:20 AM   #2
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Essex, Maryland
Posts: 6,931
Default

Welcome aboard

So in the water and in reverse you hear a clicking noise while Turing the wheel side to side, correct? Only in reverse? What about trimming up and down?
__________________

__________________
Mike
mmwjr is offline   Reply With Quote
Old 05-14-2019, 01:59 AM   #3
Ensign
 
Join Date: May 2019
Posts: 4
Default

That would be with the trim all the way down.
Bobaluah is offline   Reply With Quote
Old 05-14-2019, 02:17 AM   #4
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Essex, Maryland
Posts: 6,931
Default

Does the boat go in reverse? May be dog clutch slipping do to misadjustment of shift cable or worn clutch.
__________________
Mike
mmwjr is offline   Reply With Quote
Old 05-14-2019, 03:03 PM   #5
Ensign
 
Join Date: May 2019
Posts: 4
Default Steeering

Yes the boat will go in reverse ,but it makes that clicking noise. More if you turn the wheel left or right. I just had the Helm replaced. But it made that noise before.
Bobaluah is offline   Reply With Quote
Old 05-14-2019, 03:52 PM   #6
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Essex, Maryland
Posts: 6,931
Default

Can you post a video so we can hear the noise?
__________________
Mike
mmwjr is offline   Reply With Quote
Old 05-14-2019, 04:16 PM   #7
Ensign
 
Join Date: May 2019
Posts: 4
Default

No the boat is in the back yard. Not in any water.
Bobaluah is offline   Reply With Quote
Old 05-15-2019, 12:18 AM   #8
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Essex, Maryland
Posts: 6,931
Default

Quote:
Originally Posted by Bobaluah View Post
No the boat is in the back yard. Not in any water.
Next time you take it out?
__________________
Mike
mmwjr is offline   Reply With Quote
Old 05-15-2019, 04:14 AM   #9
Lt. Commander
 
MoonRiver's Avatar
 
Join Date: Oct 2017
Location: Spokane, WA
Posts: 159
Default

Could it be the coupler going bad?
MoonRiver is offline   Reply With Quote
Old 05-15-2019, 11:17 AM   #10
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Essex, Maryland
Posts: 6,931
Default

Quote:
Originally Posted by MoonRiver View Post
Could it be the coupler going bad?
Possibly but I would think it would happen in either direction or more in forward since there is more use in that direction.
__________________

__________________
Mike
mmwjr is offline   Reply With Quote
Reply

Tags
problem, steering

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 03:40 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.