Thread Tools Search this Thread Display Modes
Old 04-04-2017, 06:13 PM   #1
Join Date: Dec 2016
Posts: 7
Default cockpit lights not working

Hello everyone! I Have a 1995 2700 scr and the cockpit lights and also the radar arch lights are not working. Bulbs appear to be fine. Is there a fuse that controls the accessory lighting? Where would be the best place to start troubleshooting? Thank you for any advice you can give me!

riegfrghtl is offline   Reply With Quote
Old 04-04-2017, 07:23 PM   #2
Lt. JG
Join Date: Sep 2016
Location: Sweden, town Piteň.
Posts: 23

Start checking the fuses, I dont know on your boat, but on my -99 2800scr they are "under " the steering wheel.

DanielB is offline   Reply With Quote
Old 04-05-2017, 12:45 AM   #3
mmwjr's Avatar
Join Date: Feb 2012
Location: Perry Hall, Maryland
Posts: 5,628

Welcome aboard

The fuses are probably under the helm behind a panel. Check the fuse and if ok a volt meter or 12V test light is needed to trace the power to see where it stops.

Start at the fuse box then the accessory switch then each light socket. Be sure to test the ground is good as well.
mmwjr is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 03:08 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.