Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-29-2017, 05:47 PM   #1
Ensign
 
Join Date: Apr 2017
Posts: 9
Default Outdrive problems? 1997 3000SCR. Alpha 2 out drives. 4.3 twin V6

Thought I had spun hub. Replaced aluminum props and new hubs, getting same results as before.

Works fine at low rpm. With tabs down, high RPM, something is slipping. Engines or engine revs but will not put any power to prop to get on plane. Maybe prop stops spinning not sure. Have read where could be coupling issues? Estimate of cost if so? Any advice or opinions of issue greatly appreciated.




Sent from my iPhone using Tapatalk
__________________

seanbaker2010 is offline   Reply With Quote
Old 04-29-2017, 08:20 PM   #2
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Perry Hall, Maryland
Posts: 5,855
Default

If not a spun prop then the engine coupler may have spun. Check for signs of rubber or a burnt rubber smell at the back of the engines. Are they both over reving?
__________________

__________________
Mike
mmwjr is offline   Reply With Quote
Old 04-29-2017, 08:42 PM   #3
Ensign
 
Join Date: Apr 2017
Posts: 9
Default

Quote:
Originally Posted by mmwjr View Post
If not a spun prop then the engine coupler may have spun. Check for signs of rubber or a burnt rubber smell at the back of the engines. Are they both over reving?


Hard tell if both seems like only one. No smell of rubber etc. Engine coupler major deal? Pricey $?


Sent from my iPhone using Tapatalk
seanbaker2010 is offline   Reply With Quote
Old 04-29-2017, 09:40 PM   #4
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Perry Hall, Maryland
Posts: 5,855
Default

Quote:
Originally Posted by seanbaker2010 View Post
Hard tell if both seems like only one. No smell of rubber etc. Engine coupler major deal? Pricey $?


Sent from my iPhone using Tapatalk

Well the engine needs to be removed to replace it so I would expect a boat buck ($1000). Depends on labor rate in your area.
__________________
Mike
mmwjr is offline   Reply With Quote
Old 04-29-2017, 10:57 PM   #5
Ensign
 
Join Date: Apr 2017
Posts: 8
Default

"Outdrive problems? 1997 3000SCR..."

I'm new to this forum but I wonder if this post would get more response if posted to "Sport Cruisers, 22 - 30 foot Cruisers, A place just for Sport Cruiser Owners"
gbriand is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 03:59 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.