Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-25-2017, 01:31 PM   #1
Lt. JG
 
Marty87's Avatar
 
Join Date: Mar 2017
Location: U.K. Scotland
Posts: 36
Default Servicing

Hey fellow maxum owners I have just purchased a maxum 290scr 2001 model it has twin mercruiser 4.3 v6 thunderbolt ignition engines with 576 hours on both it has mercruiser bravo 2 legs on it I am going to be doing servicing on both engines and legs any tips, always my rev counter isn't work but hours still clocking up as engines run and oil gauage stuck at 40 any tips on sorting them.

Thanks
Marty
__________________

Marty87 is offline   Reply With Quote
Old 03-25-2017, 03:37 PM   #2
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Perry Hall, Maryland
Posts: 5,855
Default

Welcome aboard and congrats on the new to you boat

Get a mercruiser manual which can be found under Documents of this site and follow it service recommendation it also has troubleshooting tips.

For the tach, rev counter on the back is a switch for 4-6-8 cylinder try rotating it back and forth to see if that corrects the problem. Also verify the S terminal is seeing a pulsed signal between 2-10 volts DC.

The oil pressure issue may be a stuck gauge so try disconnecting the wire on the S terminal. If still reading 40 the gauge is faulty.
__________________

__________________
Mike
mmwjr is offline   Reply With Quote
Old 03-25-2017, 04:42 PM   #3
Lt. JG
 
Marty87's Avatar
 
Join Date: Mar 2017
Location: U.K. Scotland
Posts: 36
Default

Thanks I'll give it a try forgot to add that my tilt and trim are not working on both legs any idea is this a common fault it's just funny that both aren't working

Regards
Marty87 is offline   Reply With Quote
Old 03-25-2017, 09:22 PM   #4
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Perry Hall, Maryland
Posts: 5,855
Default

Do they not work at all or just not trim up? If the latter do they trim up using the trailer button?
__________________
Mike
mmwjr is offline   Reply With Quote
Old 03-26-2017, 05:24 PM   #5
Lt. JG
 
Marty87's Avatar
 
Join Date: Mar 2017
Location: U.K. Scotland
Posts: 36
Default

Thanks I'll shall give these a try not due back to the boat for a week or so currently away at work but I shall reply once tried to let you know how the outcome was
Marty87 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 12:08 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.