Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-05-2012, 02:34 PM   #1
Lieutenant
 
GlennW's Avatar
 
Join Date: Sep 2011
Location: Plano, Tx
Posts: 69
Default impeller

I have a 99 3000 screen with merc sterns. Are the impellers on the drives or are they on the engine?
I've replaced them on the older alpha one but unsure of location on these.
Alarm is going off @ 190* and engine shuts down.
__________________

__________________
It's an obsession....coupled with a sickness!
GlennW is offline   Reply With Quote
Old 05-05-2012, 03:49 PM   #2
Admiral

 
seapuppy's Avatar
 
Join Date: Nov 2005
Location: Everett Wa
Posts: 4,681
Default

what drive do you have.???..if you have any of the "B" models..b2 or b3..the impellers are located on the right side of the engine.....run by a fan belt....if you have any of the alpha drives...then it's in the lower part of the drives ....which requires the 6 bolts that hold the drive to come off and the impeller is on the top of the lower drive....


SP
__________________
Don't compare your life to others. You have no idea what their journey is all about.
------------------------
SSN683 Association member
Par Excellence
------------------------------
2008 Bayliner 340 - "Wild Whim"
--------------------------------------
I live in my own little world....but it's okay-they know me here!!!

Avid practitioner of the martial art: KLIK-PAO.
Tap-Rack-Bang

Anyone that sez "Size doesn't matter" has never owned a boat!
seapuppy is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 09:39 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.