Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-02-2005, 06:18 PM   #1
Ensign
 
Join Date: Jul 2005
Location: New York
Posts: 7
Default Water in distributor

I have a 2004 2500 se . Does anyone else have a problem with water getting in to their distributor? I have had to clean out mine twice and replace once since july 4 th Its a 5.7 merc bravoIII
Attached Images
File Type: bmp untitled.bmp (306.3 KB, 70 views)
File Type: jpg !cid_1.jpg (267.6 KB, 69 views)
File Type: jpg boat.JPG (44.9 KB, 43 views)
File Type: jpg cool.JPG (32.9 KB, 34 views)
File Type: jpg P3130194.JPG (29.4 KB, 34 views)
File Type: jpg P5260210.JPG (31.2 KB, 36 views)
File Type: jpg P5260205.JPG (38.1 KB, 33 views)
File Type: jpg P5270225.JPG (46.3 KB, 34 views)
__________________

__________________
You call it jogging ,I call it runnin around
bayracerL.I. is offline   Reply With Quote
Old 08-02-2005, 06:36 PM   #2
Lt. Commander
 
Join Date: Jun 2005
Location: Lk Stevens, WA
Posts: 113
Default

Bay any idea where the water is coming from? - Never had this problem with any of my boats. The only insite I can offer is a marine dist. cap has a gasket between the cap and dist. base. If it has been replaced with an automotive one there will be no gasket.
__________________

__________________
Ken
1999 3788 Alrighty Then Port of Everett
2000 2100SCZ Maxum Lake Chelan
alrightythen@iboatnw.com
3388sam is offline   Reply With Quote
Old 08-05-2005, 08:59 PM   #3
Ensign
 
Join Date: Jul 2005
Location: New York
Posts: 7
Default

The water is draining off the engine hatch and running in to the dist. There are 2 drains on port and star sides under the hatch that are free and clear of debris .
Attached Images
File Type: jpg 014.JPG (108.6 KB, 13 views)
File Type: png 40486a2b.png (96.7 KB, 44 views)
File Type: png c7193902.png (131.8 KB, 38 views)
File Type: png c60672c0.png (93.3 KB, 39 views)
File Type: png a1145150.png (97.9 KB, 72 views)
__________________
You call it jogging ,I call it runnin around
bayracerL.I. is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intermitant Fault with mag 350 MPI gentlemanglobetrotter Engines 23 07-16-2010 06:27 PM
Question, re: Generators and inverters T.A. Sarles Engines 7 05-03-2008 02:33 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 08:24 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.