Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-06-2019, 12:40 PM   #1
Ensign
 
Join Date: May 2019
Location: Buffalo, New York
Posts: 5
Default Oil pressure

Hi all, I have a 1999 Maxum 2800 with twin 4.3 mercs. Recently my oil pressure gauge has been reading high (just under 80) when running at higher rpms. No issue when running at lower rpms. Now the alarm has started to go off as well. Has anyone had a similar issue that can share how to troubleshoot? Thanks
__________________

Upper Mike is offline   Reply With Quote
Old 09-06-2019, 12:44 PM   #2
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Essex, Maryland
Posts: 7,351
Default

In the Mercruiser manual for your engine there is a chart that tells you what the resistance should be for the oil pressure sender at several rpm. The manual can be found under Documents of this site.

Next you can use a manual oil pressure gauge to verify the pressure. Worst case is the pressure relief valve is sticking on the oil pump.
__________________

__________________
1997 2400 SCR
5.7 Vortec / Bravo 2
Mike
mmwjr is offline   Reply With Quote
Old 09-06-2019, 01:14 PM   #3
Ensign
 
Join Date: May 2019
Location: Buffalo, New York
Posts: 5
Default

Thanks appreciate the advice.
Upper Mike is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 04:22 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.