Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-11-2019, 12:41 PM   #1
Ensign
 
Join Date: Aug 2019
Posts: 3
Default Max RPM

Hi, I have a 2005 Maxum 2500SE with 5.0 MPI bravo 111, it wont go over 4000 rpm and beeps twice every 10 minutes, What do you think the problem is? thank you
__________________

jimmy h is offline   Reply With Quote
Old 08-19-2019, 02:05 PM   #2
Ensign
 
Join Date: Aug 2019
Posts: 3
Default

It was the map sensor!
__________________

jimmy h is offline   Reply With Quote
Old 08-19-2019, 03:00 PM   #3
Admiral
 
Phillbo's Avatar
 
Join Date: Mar 2012
Location: Lake Powell
Posts: 1,188
Default

I'm guessing the Map Sensor

Thanks for following up with the resolution.
Phillbo is offline   Reply With Quote
Old 08-19-2019, 04:08 PM   #4
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Essex, Maryland
Posts: 7,267
Default

Good to know that's for posting your findings.
__________________
1997 2400 SCR
5.7 Vortec / Bravo 2
Mike
mmwjr is offline   Reply With Quote
Old 08-19-2019, 06:20 PM   #5
Ensign
 
Join Date: Aug 2019
Posts: 3
Default

Thanks
jimmy h is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 08:26 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.