Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-22-2013, 01:42 PM   #11
Moderator

 
Join Date: Apr 2008
Posts: 3,551
Default

Quote:
Originally Posted by Penns Beach View Post
The volt gauge stays right on 122 volts it
12.2volts? not 14?
__________________

__________________
Leave me alone, it's Boating Season!!!
shrew is offline   Reply With Quote
Old 05-22-2013, 03:18 PM   #12
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Perry Hall, Maryland
Posts: 5,393
Default

I would use a hand help voltmeter to verify. 12.2V is what I would expect the battery to be with the engine off and no load. with engine on should be 13 - 14V.
__________________

__________________
Mike
mmwjr is online now   Reply With Quote
Old 05-22-2013, 05:28 PM   #13
Lt. JG
 
Join Date: May 2010
Posts: 43
Default

the volt meter when running is 14 I hooked a pressure meter to the fuel system and started the engine It went right to 40 lbs then immediately started dropping off down to 20 lbs. I think it might be the fuel pressure regualtor of the fuel pump. What are your thoughts?
Penns Beach is offline   Reply With Quote
Old 05-22-2013, 06:40 PM   #14
Admiral

 
ss3964spd's Avatar
 
Join Date: Jul 2009
Location: Fairfax Va
Posts: 1,512
Send a message via Yahoo to ss3964spd
Default

You said it's a 5.7, but which one?
ss3964spd is offline   Reply With Quote
Old 05-23-2013, 12:36 AM   #15
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Perry Hall, Maryland
Posts: 5,393
Default

Based on the fuel pressure I am assuming you have a mpi engine,as ss3964spd asked what engine package do you have? I did a quick search and it seems that 40 psi is the normal pressure. The fault could be the pump or the fuel regulator on the fuel rail. Question: when you made the measurements (voltage amd pressure) was the RPMs low? I would think that all measurements would be in th acceptable range is engine is running correctly and would only be abnormal when RPMs drop, but that's my thinking.
__________________
Mike
mmwjr is online now   Reply With Quote
Old 05-23-2013, 05:32 PM   #16
Lt. JG
 
Join Date: May 2010
Posts: 43
Default

It's a 350 5.7 MPI with a Bravo 3. Mike "mmwjr" I see your in Kingsville We dock the boat in Havre de Grace at Penns Beach. I am taking it to Tomes Landing tonight. They are going to look at everything you all mentioned. I thank everyone for their input. I will let you know the outcome.
Penns Beach is offline   Reply With Quote
Old 05-23-2013, 09:52 PM   #17
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Perry Hall, Maryland
Posts: 5,393
Default

Penns, you're welcome and good luck. BTY i checked my merc manual and it says fuel pressure should be 30 psi, turn key to run but don't start to measure is the instructions they give.

look forward to hearing the outcome
__________________

__________________
Mike
mmwjr is online now   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 12:34 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.