Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-05-2017, 12:06 AM   #11
Admiral
 
biggerseagar's Avatar
 
Join Date: Dec 2010
Location: central Illinois
Posts: 1,894
Default

Who did u buy it from?

Roger
__________________

biggerseagar is offline   Reply With Quote
Old 09-05-2017, 12:14 AM   #12
Lieutenant
 
Join Date: Jul 2011
Location: New Jersey
Posts: 57
Default

I believe it was mercruiserparts.com. I had the mechanic order it for me and it took about a week to get.

Sent from my SM-G955U1 using Tapatalk
__________________

jayesq is offline   Reply With Quote
Old 09-05-2017, 03:15 AM   #13
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Perry Hall, Maryland
Posts: 5,396
Default

Roger did you let the engine warm up? Sounds to me like the choke is not opening. Even when cold an increase in throttle will cause it to open to allow more air flow.
__________________
Mike
mmwjr is offline   Reply With Quote
Old 09-05-2017, 05:34 PM   #14
Admiral
 
biggerseagar's Avatar
 
Join Date: Dec 2010
Location: central Illinois
Posts: 1,894
Default

Mike I did...... At idle rpm's for a good 10 15 minutes and when I could feather it up to around 2000. As soon as I lowered the throttle it died.

Roger
biggerseagar is offline   Reply With Quote
Old 09-05-2017, 09:02 PM   #15
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Perry Hall, Maryland
Posts: 5,396
Default

Quote:
Originally Posted by biggerseagar View Post
Mike I did...... At idle rpm's for a good 10 15 minutes and when I could feather it up to around 2000. As soon as I lowered the throttle it died.

Roger
Did you remove the flame arrestor and verify the choke opened? May just be time for a rebuild.
__________________
Mike
mmwjr is offline   Reply With Quote
Old 09-06-2017, 12:32 AM   #16
Admiral
 
biggerseagar's Avatar
 
Join Date: Dec 2010
Location: central Illinois
Posts: 1,894
Default

No I just gave up and had opened up a blue moon!

Roger
biggerseagar is offline   Reply With Quote
Old 09-06-2017, 03:06 AM   #17
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Perry Hall, Maryland
Posts: 5,396
Default

Quote:
Originally Posted by biggerseagar View Post
No I just gave up and had opened up a blue moon!

Roger
Nothing wrong with that.
__________________
Mike
mmwjr is offline   Reply With Quote
Old 09-07-2017, 08:08 PM   #18
Admiral
 
biggerseagar's Avatar
 
Join Date: Dec 2010
Location: central Illinois
Posts: 1,894
Default

Carb update...... starboard side carb is off and being inspected at the shop.......film at 11.... hope to have the prognosis soon.

Roger
biggerseagar is offline   Reply With Quote
Old 09-08-2017, 09:22 PM   #19
Admiral
 
biggerseagar's Avatar
 
Join Date: Dec 2010
Location: central Illinois
Posts: 1,894
Default

Carb insides shot ...waiting for rebuilt kit....hopefully up and running Monday afternoon.

Roger
biggerseagar is offline   Reply With Quote
Old 09-08-2017, 09:55 PM   #20
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Perry Hall, Maryland
Posts: 5,396
Default

Quote:
Originally Posted by biggerseagar View Post
Carb insides shot ...waiting for rebuilt kit....hopefully up and running Monday afternoon.

Roger
At least that answers the mail on the issue.
__________________

__________________
Mike
mmwjr is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 12:13 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.