Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-03-2016, 01:14 AM   #1
Lt. JG
 
martynj19's Avatar
 
Join Date: May 2016
Location: Brisbane
Posts: 19
Default Blower question

Hi all, I have recently purchased a 1900 SR3 4.3 carb and I am going over the boat for my own piece of mind (checking connections and general lookaround) I have tested the blower system and found hole at the back of the ducting where it leaves the fan unit , fixed this no problem. When I operate the blower out of the water , I find the exhausted air exiting the port side vent , but I have noticed that air is also coming out of the fresh air ducting next to the battery. Is this normal ? maybe back pressure ? Any help is appreciated.

Martyn
__________________

martynj19 is offline   Reply With Quote
Old 05-03-2016, 01:17 AM   #2
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Perry Hall, Maryland
Posts: 5,401
Default

Typically the blower only has one output and draws from the lowest point in the bilge.

There is a fresh air intake that bring air into the engine compartment about the height of the engine mounts and is non powered.
__________________

__________________
Mike
mmwjr is offline   Reply With Quote
Old 05-03-2016, 01:50 AM   #3
Lt. JG
 
martynj19's Avatar
 
Join Date: May 2016
Location: Brisbane
Posts: 19
Default

Hi Mike , that is correct as per my installation , I cannot see how the ducting is terminated in the port side vent area , I am presuming that they should be seperated , but a certain amount of air definately comes out of the unpowered duct when the blower is on. Is there a schematic that shows the detail I am after?

Thanks

Martyn
martynj19 is offline   Reply With Quote
Old 05-03-2016, 02:29 AM   #4
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Perry Hall, Maryland
Posts: 5,401
Default

Here is a link with some generic diagrams.

boat blower ventilation systems

Ok that did not work.
__________________
Mike
mmwjr is offline   Reply With Quote
Old 05-03-2016, 02:35 AM   #5
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Perry Hall, Maryland
Posts: 5,401
Default

Ok iPad is not letting me copy links of images.

Google boat engine ventalation systems.
__________________
Mike
mmwjr is offline   Reply With Quote
Old 05-03-2016, 02:39 AM   #6
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Perry Hall, Maryland
Posts: 5,401
Default

Try this

Bilge Blower Hose Routing Question - The Hull Truth - Boating and Fishing Forum
__________________
Mike
mmwjr is offline   Reply With Quote
Old 05-03-2016, 02:53 AM   #7
Lt. JG
 
martynj19's Avatar
 
Join Date: May 2016
Location: Brisbane
Posts: 19
Default

Hi Mike , much appreciated , I think it is as I have suspected in that the blower is pressurising the port vent box and excess exhausted air is making its way down the "fresh" air ductwork. I will look into modifying it as per the install drawings you linked. Or investigate the vent connections further.
Thanks again.
Martyn
martynj19 is offline   Reply With Quote
Old 05-03-2016, 03:32 AM   #8
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Perry Hall, Maryland
Posts: 5,401
Default

A blower should always draw out of the engine compartment and only pull air in from a fresh supply to cross ventilate.
__________________

__________________
Mike
mmwjr is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 05:47 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.