Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-01-2010, 06:19 PM   #1
Ensign
 
Join Date: May 2008
Location: st. petersburg, Florida
Posts: 8
Default 3.0l carburetor dumping fuel

i have an 2006 3.0L the fuel is is just pouring from the venturi cluster does anyone have any idea what would cause this?
__________________

tomjentommy is offline   Reply With Quote
Old 05-02-2010, 05:00 PM   #2
Admiral

 
seapuppy's Avatar
 
Join Date: Nov 2005
Location: Everett Wa
Posts: 4,681
Default

well...gonna have to give me more info than this.....if the fuel is dumping out the venturi cluster...is the engine running???...if the engine is running..it's supposed to do that..but if the engine is not running ...then you have a bad carb and needs a rebuild ....the seating needle valve that attaches to the float is not stopping the fuel flow.....


SP
__________________

__________________
Don't compare your life to others. You have no idea what their journey is all about.
------------------------
SSN683 Association member
Par Excellence
------------------------------
2008 Bayliner 340 - "Wild Whim"
--------------------------------------
I live in my own little world....but it's okay-they know me here!!!

Avid practitioner of the martial art: KLIK-PAO.
Tap-Rack-Bang

Anyone that sez "Size doesn't matter" has never owned a boat!
seapuppy is offline   Reply With Quote
Old 05-05-2010, 12:49 AM   #3
Ensign
 
Join Date: May 2008
Location: st. petersburg, Florida
Posts: 8
Default

Ok well i was being a bit lazy with my description. I will start over the boat had been sitting for a while and would idle but would stall during acceleration, i came to the conclusion that the carb need to be rebuilt and since several years ago i had rebuilt many carbs i did not think it would be a big deal. i rebuilt carb, reinstalled and started ran fantastic for roughly two minutes then stalled and would not restart so when i peeked into the carb i noticed that the fuel was just continually dumping from the veturi cluster. i had never seen this before and figured i screwed up somewhere. thanks for any input on this my wife already thinks i am a moron i am trying to prove her wrong!
tomjentommy is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 06:14 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.