Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-07-2017, 10:22 PM   #11
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Perry Hall, Maryland
Posts: 5,401
Default

Ok but why is the alarm sounding? Two bad sendors that fail at the same time???

I hope that's it, much cheaper than an engine.
__________________

__________________
Mike
mmwjr is offline   Reply With Quote
Old 09-07-2017, 10:26 PM   #12
Ensign
 
Join Date: Sep 2017
Location: Sayville, NY
Posts: 6
Default

Well looks like the oil pressure gauge in the dash is bad you have to whack it good to get a real racing lol. Isn't there an oil pressure sending sensor?
__________________

Midnj321 is offline   Reply With Quote
Old 09-08-2017, 03:17 AM   #13
Admiral
 
mmwjr's Avatar
 
Join Date: Feb 2012
Location: Perry Hall, Maryland
Posts: 5,401
Default

Quote:
Originally Posted by Midnj321 View Post
Well looks like the oil pressure gauge in the dash is bad you have to whack it good to get a real racing lol. Isn't there an oil pressure sending sensor?
Yes there is a sendor for the oil gauge but the alarm uses a separate oil pressure switch. So either the OP switch and the gauge are bad or something else is triggering the alarm, gear lube level or over temp.
__________________

__________________
Mike
mmwjr is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 02:00 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.