Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-26-2010, 11:28 PM   #1
Ensign
 
Join Date: Oct 2009
Location: Gunpowder Cove Maryland
Posts: 8
Default 2004 2700 SE Spotlight

Im having trouble with my spotlight , its not getting power . Anyone know where the fuse is . There is no dedicated breaker for it .
__________________

FinalMatch is offline   Reply With Quote
Old 05-26-2010, 12:06 AM   #2
Lieutenant
 
capav8r's Avatar
 
Join Date: Oct 2009
Location: Johnston, Iowa, United States
Posts: 79
Default

hopefully you have found an answer by now, but mine (ITT Jabsco) has 2 fuses right in the controller. They are to each side of the joystick under little black covers.
__________________

capav8r is offline   Reply With Quote
Old 02-06-2011, 03:18 PM   #3
Ensign
 
Join Date: Oct 2009
Location: Gunpowder Cove Maryland
Posts: 8
Default

It must have been a lose or oxidized conection . I took the control panel apart 3 times and couldn't find a problem then on the 3rd reassemble the light came on and has been on all season. I only sprayed a little woody wax on the fuse blades but they realy didnt look like they needed it. oh well you got to love the easy fixes
FinalMatch is offline   Reply With Quote
Old 02-06-2011, 03:38 PM   #4
Admiral

 
seapuppy's Avatar
 
Join Date: Nov 2005
Location: Everett Wa
Posts: 4,681
Default

I was going to suggest checking the blades of the fuses at the control panel...


glad it all worked out

SP
__________________
Don't compare your life to others. You have no idea what their journey is all about.
------------------------
SSN683 Association member
Par Excellence
------------------------------
2008 Bayliner 340 - "Wild Whim"
--------------------------------------
I live in my own little world....but it's okay-they know me here!!!

Avid practitioner of the martial art: KLIK-PAO.
Tap-Rack-Bang

Anyone that sez "Size doesn't matter" has never owned a boat!
seapuppy is offline   Reply With Quote
Old 02-07-2011, 11:54 AM   #5
Moderator

 
Join Date: Apr 2008
Posts: 3,558
Default

Final Match,

WOW!!! Thank you very much for taking the time to follow-up on this one. There is nothing worse than a dead thread. I got so sick of chasing 12V issues I replaced both 12v fuse buses, all the connectors and all the fuses. It made a big difference.
__________________
Leave me alone, it's Boating Season!!!
shrew is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 12:04 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.